zukucode
主にWEB関連の情報を技術メモとして発信しています。

Electronをインストール時にエラーになってしまうときの対処法

Electronをインストールするときにエラーになってしまいました。

いろいろ調べて無事にインストールできたのでそのときのメモです。

環境

ElectronをインストールしたパソコンのOSLinuxです。

nodejsnpmのバージョンは以下のとおりです。

$ node -v
v9.2.1

$ npm -v
5.6.0

インストールしたElectronのバージョンは1.7.10です。

エラー内容

以下のコマンドでインストールしようとしたところ、node install.jsの処理でしばらく時間がかかり、気がつくとエラーになっていました。

$ npm install electron --save-dev

対処法

いろいろと調べたところ、権限が足りていないようでした。

管理者権限(sudo)で実行しても同様のエラーになってしまうので、--unsafe-perm=trueのコマンドを追加します。

$ npm i electron --save-dev --unsafe-perm=true

これで無事にインストールできました。



関連記事